https://allseenalliance.org/developers/develop/building/linux/openwrt

Patch OpenSSL

For Barrier Breaker, use 39048 or later, or apply patch 4576 (The latest version of Barrier Breaker, aka trunk, already has the patch applied.)

My Checked out revision 46386. 2015/7/16,Barrier Breaker

No Patch OpenSSL is needed

nano feeds.conf.default
src-git alljoyn src-git alljoyn https://git.allseenalliance.org/gerrit/core/openwrt_feed;barrier_breaker
./scripts/feeds update  alljoyn
./scripts/feeds install -p alljoyn -a
make menuconfig

compile it:

make  -j 9  V=s